wolfSSL 5.9.4 リリース
wolfSSL 5.9.4 をリリースしました。本リリースでは、新しい暗号アルゴリズムの追加、耐量子暗号対応の拡充、新たなハードウェアへの対応、大規模なアセンブリ最適化に加え、複数の脆弱性を修正しました。wolfSSL は常に最新リリースへの更新をお勧めしています。本リリースで修正した重要度 High の脆弱性の影響を受けるユースケースは次のとおりです。 信頼済みピア証明書(WOLFSS…… もっと読む
wolfSSL 5.9.4 をリリースしました。本リリースでは、新しい暗号アルゴリズムの追加、耐量子暗号対応の拡充、新たなハードウェアへの対応、大規模なアセンブリ最適化に加え、複数の脆弱性を修正しました。wolfSSL は常に最新リリースへの更新をお勧めしています。本リリースで修正した重要度 High の脆弱性の影響を受けるユースケースは次のとおりです。 信頼済みピア証明書(WOLFSS…… もっと読む
Anthropic は、オープンソースソフトウェアのセキュリティ強化を目的とした、AI による新たな脆弱性検出サービス「OSS Scanner」を発表しました。この発表の中で wolfSSL が紹介されています。 wolfSSL のCTO、 Todd Ouska は、検出結果の質について次のようにコメントしています。 「いただいたレポートは、有効な指摘の割合が高いと感じました。74…… もっと読む
wolfSSL は、NIST の耐量子暗号アルゴリズム一式を STM32C5 上で動作させています。以下は、144 MHz の Cortex-M33 を搭載した NUCLEO-C5A3ZG での測定結果です。 ML-KEM(FIPS 203)による鍵交換:ML-KEM-768 のカプセル化は 5.9 ms、デカプセル化は 7.7 ms ML-DSA(FIPS 204)による署名:3…… もっと読む
wolfSSH v1.6.0 をリリースしました。本リリースでは、5件の脆弱性修正、厳格な鍵交換(Strict KEX)のデフォルト有効化、ML-DSA によるホスト鍵とユーザー認証への対応に加え、wolfSSH 史上最大規模の堅牢化を実施しました。いくつかのデフォルト設定を変更していますので、アップグレードの前に「動作の変更点」をご確認ください。すべての変更点については ChangeLog.m…… もっと読む
wolfMQTT は、組み込み機器や IoT デバイス向けに設計した、wolfSSL の軽量な MQTT クライアントおよびブローカーライブラリです。小型で移植性が高く、組み込み向け TLS ライブラリである wolfSSL と直接組み合わせて、TLS 1.3 による安全な MQTT 通信を実現できます。wolfMQTT 2.2.0 では、キープアライブのスケジュール管理をアプリケーション側で行…… もっと読む
wolfCOSE v2.0.0 では、次の4つの機能を追加しました。本記事では、それぞれの概要と対応するプルリクエストをまとめてご紹介します。 COSE HPKE 暗号化(PR #70) 耐量子 LMS 署名(PR #72) COSE カウンター署名(PR #74) PSA アテステーションと EAT(PR #75) v2.0.0 のその他の変更点については、w…… もっと読む
wolfMQTT は10年にわたり、クライアントライブラリとしてのみ提供してきました。v2.0.0 では、新たに軽量な MQTT ブローカーを追加しました。クライアントと同じコードベース上に構築し、厳しいフットプリント要件と TLS スタックをそのまま引き継いでいます。直近の2回のリリースでは、プロセスを再起動しても状態を保持するために必要な中核機能を追加したほか、ネットワークに高い負荷がかかっ…… もっと読む
wolfCOSE 2.0.0 をリリースしました。wolfCOSE は、wolfCrypt をベースに構築した、動的メモリ割り当てを一切行わない CBOR(RFC 8949)と COSE(RFC 9052)の完全な C 実装です。メジャーアップデートとなる今回のリリースでは、標準化された HSS/LMS ステートフルハッシュベース署名、RFC 9338 副署名、RFC 9783 PSA/EAT …… もっと読む
wolfSSL は、商用の TLS / 暗号ライブラリの中でも最も小さい部類に入ります。最大の課題は、どの設定項目を選ぶかです。本記事では、特に効果の大きい 10 の設定項目を簡単に紹介します。 ビルドを設定する 2 つの方法 以下で紹介する定義やフラグは、次のどちらの方法でも指定できます。 Autoconf / configure(./configure):--enable…… もっと読む
7 月の wolfMQTT 2.1.0 リリース以降、開発チームはいくつかの大きな改良に取り組んできました。クライアントとブローカーのどちらをお使いの方にも、GitHub の master ブランチには注目していただきたい変更が数多く入っています。開発者体験の向上とプロトコル準拠の厳密化に加え、何より本格的なセキュリティ強化に注力しました。 主な変更点は次のとおりです。 キープアラ…… もっと読む