wolfSSH v1.6.0 をリリースしました

wolfSSH v1.6.0 をリリースしました。本リリースでは、5件の脆弱性修正、厳格な鍵交換(Strict KEX)のデフォルト有効化、ML-DSA によるホスト鍵とユーザー認証への対応に加え、wolfSSH 史上最大規模の堅牢化を実施しました。いくつかのデフォルト設定を変更していますので、アップグレードの前に「動作の変更点」をご確認ください。すべての変更点については ChangeLog.m…… もっと読む

wolfMQTT 2.2.0 をリリースしました:キープアライブの自動化、セッション再開時の再送、より厳格な MQTT 仕様準拠

wolfMQTT は、組み込み機器や IoT デバイス向けに設計した、wolfSSL の軽量な MQTT クライアントおよびブローカーライブラリです。小型で移植性が高く、組み込み向け TLS ライブラリである wolfSSL と直接組み合わせて、TLS 1.3 による安全な MQTT 通信を実現できます。wolfMQTT 2.2.0 では、キープアライブのスケジュール管理をアプリケーション側で行…… もっと読む

wolfCOSE v2.0.0 をリリースしました

wolfCOSE 2.0.0 をリリースしました。wolfCOSE は、wolfCrypt をベースに構築した、動的メモリ割り当てを一切行わない CBOR(RFC 8949)と COSE(RFC 9052)の完全な C 実装です。メジャーアップデートとなる今回のリリースでは、標準化された HSS/LMS ステートフルハッシュベース署名、RFC 9338 副署名、RFC 9783 PSA/EAT …… もっと読む

wolfSSL 5.9.4 リリース

wolfSSL 5.9.4 をリリースしました。本リリースでは、新しい暗号アルゴリズムの追加、耐量子暗号対応の拡充、新たなハードウェアへの対応、大規模なアセンブリ最適化に加え、複数の脆弱性を修正しました。wolfSSL は常に最新リリースへの更新をお勧めしています。本リリースで修正した重要度 High の脆弱性の影響を受けるユースケースは次のとおりです。 信頼済みピア証明書(WOLFSS…… もっと読む

wolfTPM v4.2.0 をリリースしました

wolfTPM 4.2.0 では、ファームウェア TPM(fwTPM)における TCG TPM 2.0 v1.85 仕様への準拠、TLS 1.3 の認証までを対象とした耐量子暗号対応の拡張、そして新しいプラットフォーム向けバックエンドの追加を中心に開発を進めました。これにより、マイクロコントローラーから Linux エッジデバイスまで幅広いハードウェアにおいて、標準に準拠し耐量子暗号にも対応した…… もっと読む

wolfProvider 1.2.2 をリリースしました

wolfProvider 1.2.2 をリリースしました。wolfProvider は OpenSSL 3.x のプロバイダーとして、暗号処理を wolfCrypt FIPS 140-3 モジュールで実行します。これにより、既存の OpenSSL アプリケーションは、コードを一切変更することなく FIPS 認証取得済みの暗号処理基盤を利用できます。本リリースでは、Windows へのネイティブ対…… もっと読む

wolfEngine 1.4.1 をリリースしました

wolfEngine 1.4.1 をリリースしました。wolfEngine は、wolfCrypt FIPS 140-3 暗号モジュールをバックエンドとする OpenSSL エンジンです。OpenSSL 1.0.2 および 1.1.1 を使用するレガシーなアプリケーションに、コードを変更することなく FIPS 認証取得済みの暗号機能を提供します。本アップデートでは、TLS の AEAD における…… もっと読む

wolfBoot 2.9.0 をリリースしました

wolfSSL チームは、wolfBoot 2.9.0 をリリースしました。対応ハードウェアを拡大し、イメージと暗号処理に関する新しい選択肢を追加するとともに、ブートおよびアップデート処理全体のセキュリティ強化を継続しました。 対応ハードウェアの拡大 wolfBoot 2.9.0 では、以下を含む複数の新しいプラットフォームに対応しました。 STM32N6、STM32U3、S…… もっと読む

wolfTPM v4.1.0 をリリースしました

wolfTPM v4.1.0 では、v4.0.0 でお約束した耐量子暗号への移行パスを提供するとともに、ファームウェアTPM(fwTPM)の堅牢化に大きく取り組みました。主な機能は次の3つです。 TPM 2.0 v1.85 耐量子暗号:ML-DSA と ML-KEM を、ネイティブおよび fwTPM で利用できます fwTPM の堅牢化:TCG仕様に準拠した辞書攻撃対策、SPDMセキュア転…… もっと読む

wolfPKCS11 2.1.0 をリリースしました

wolfPKCS11 2.1.0 をリリースしました。本バージョンでは、PKCS#11 実装に耐量子暗号を導入し、CMake ビルドシステムと Doxygen による API ドキュメントを追加し、PKCS#11 仕様への準拠に関する多数の不足点を解消しました。あわせて、メモリ安全性の強化を実施し、CI と相互接続性テストの範囲を拡充しています。 耐量子暗号 2.1.0 の目玉は耐量…… もっと読む

Posts navigation

1 2 3 4 … 7 8 9